TAB - thinBasic Adventure Builder

T.A.B. is an interactive fiction/text adventure program for Windows and made with thinBasic.
 
HomeFAQSearchUsergroupsRegisterLog in
Latest topics
» TAB Version 66 Available
Mon Sep 26, 2016 12:02 pm by catventure

» TAB Version 65 Available
Mon Feb 23, 2015 12:04 pm by catventure

» Incubation pt 1
Wed Apr 24, 2013 9:24 am by Kabrinski

» Charecter movements - doors
Wed Mar 20, 2013 2:55 pm by garethfx

» Member feedback on game planning
Sun Mar 03, 2013 1:47 pm by garethfx

» Still alive - just!
Thu Feb 28, 2013 11:34 am by catventure

» TAB 64 crashes ...
Mon Aug 20, 2012 11:31 am by acko

» Idea on addition to object being container
Sat Aug 18, 2012 3:49 pm by catventure

» sizex=y action ...
Thu Aug 09, 2012 11:29 am by catventure


Share | 
 

 JUMPSTART = reporting response error?

View previous topic View next topic Go down 
AuthorMessage
garethfx
Experienced Adventurer


Male
Number of posts : 85
Age : 59
Location : Wales
Humor : Nothing like having a good laugh - oh and a pint!
Adventure Points : 53
Registration date : 2009-09-28

PostSubject: JUMPSTART = reporting response error?   Tue Oct 06, 2009 3:13 pm

[start]%_%#objn2=7#objn1=7#objloc7=0[acts]objn1=8#objn2=8#jumpSTART#else#objn1=7#objn2<>7#objloc7=0[acts]objn1=8#jumpSTART#else#objn2=7#objn1<>7#objloc7=0#objn2=8#jumpSTART[end]


Ive used the above to tackle issues with having a lamp in 2 differing status's. However having changed the 7 for 10(new off lamp) and 8 to 11 - light lit
I immeadiatley get the error message when making my first move in the test game

Error In Response Entry:
No Condition/action seperator

Ive even used the original (as above) to see if Id made a typo - I still get the error message

Is there an error that my inexperience isnt picking up in the original ?

Gareth
Back to top Go down
View user profile
catventure
Admin Adventurer
avatar

Male
Number of posts : 376
Age : 65
Location : UK
Humor : Enjoys a laugh!
Adventure Points : 52
Registration date : 2008-06-08

PostSubject: Re: JUMPSTART = reporting response error?   Tue Oct 06, 2009 3:24 pm

[start]%_%#objn2=7#objn1=7#objloc7=0[acts]objn1=8#objn2=8#jumpSTART#else#objn1=7#objn2<>7#objloc7=0[acts]objn1=8#jumpSTART#else#objn2=7#objn1<>7#objloc7=0[acts]objn2=8#jumpSTART[end]

Hi Gareth. Tab is right - there are no [acts] tag after the final #else# conditions. It should be OK if you change it like above... bounce

Don't worry. This is one of the most tricky parts of TAB coding that you are attempting Neutral


Phil.


Topic now locked

_________________
http://tab.thinbasic.com ; Home of the TAB I.F. project.
Back to top Go down
View user profile http://adventure.rpgdynasty.com
 

JUMPSTART = reporting response error?

View previous topic View next topic Back to top 

 Similar topics

+
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
TAB - thinBasic Adventure Builder :: TAB FORUMS :: Bug Reports-
Jump to: